问题 问答题

接入层交换机Switch1的端口24为Trunk口,其余各口属于Vlan11,请解释下列命令并完成交换机的配置。
Switchl#config terminal
Switch1(config)#interface f0/24 (进入端口24配置模式)
Switch1(config-if)# switchport mode trunk (1)
Switch1(config-if)# switchport trunk encapsulation dotlq (2)
Switch1(config-if)# switchport trunk allowed all(允许所有VLAN从该端口交换数据)
switch1(config-if)#exit
Switch1(config)#exit
Switch1# vlan database
Switch1(vlan)# vlanll name lab01 (3)
Switch1(vlan)#exit
Switch1#config terminal
Switch1(config)#intefface f0/9 (进入f0/9的配置模式)
Switch1(config-if)# (4) (设置端口为接入链路模式)
Switch1(config-if)# (5) (把f0/9分配给Vlan11)
Switch1(config-if)#exit
Switch1(config)#exit

答案

参考答案:(1) 设置端口为中继(或Trunk)模式
(2) 设置Trunk采用802.1q格式(或dotlq)
(3) 创建Vlan11,并命名为lab01
(4) switchport mode access
(5) switchport access vlan11

解析: 由题目可知,Switch1的端口24为Trunk口,其余各口属于Vlan11,故Switch1的配置及解释如下。
Switch1#config terminal
Switch1(config)#interface f0/24 (进入端口24配置模式)
Switch1(config-if)# switchport mode trunk (设置端口为中继模式)
Switch1(config-if)# switchport trunk encapsulation dotlq
(设置Trunk采用802.1q格式)
Switch1(config-if)# switchport trunk allowed all
(允许所有VLAN从该端口交换数据)
Switch1(config-if)#exit
Switch1(config)#exit
Switchl# vlan database
Switch1(vlan)# vlan11 name lab01 (创建Vlan11,并命名为lab01)
Switch1(vlan)#exit
Switch1#config terminal
Switch1(config)#interface f0/9 (进入f0/9的配置模式)
Switch1(config-if)# switchport mode access (设置端口为接入链路模式)
Switch1(config-if)# switchport access vlan11 (把f0/9分配给Vlan11)
Switch1(config-if)#exit
Switch1(config)#exit

问答题

下面是一个Applet程序,其功能是计算山顶的高度,计算方法是:该山顶由a点量得仰角度数为a度,由b点量得仰角度数为b度,且测得a,b点之间的距离为c米,求山的高度。要求窗口中有3个输入框,分别作为a,b,c的输入,一个按钮点击后进行计算,结果显示在另一个文本框中(这个文本框不可编辑)。请改正程序中的错误(有下划线的语句),使程序能输出正确的结果。
注意:不改动程序的结构,不得增行或删行。
源程序文件代码清单如下:
import java.io.*;
import java.awt.*;
import java.awt.event.*;
import java.applet.Applet;
/*
<applet code="ex6_3.class" width=800 height=400 >
</applet>
*/
public class ex6_3 extends Applet implements ActionListener

Panel pane=new Panel();
Label 11 = new Label("a 点仰角:");
TextField tfl = new TextField(5);
Label 12 = new Label("b 点仰角:");
TextField tf2 = new TextField(5);
Label 13 = new Label("a,b 之间距离:");
TextField tf3 = new TextField(5);
Button btn = new Button("OK");
Label 14=new Label ("山高");
TextField tf4=new TextField(20);
ex6_3 obj23_3;
public void init()

pane.setLayout (new FiowLayout(FlowLayout.LEFT,10,5));
pane.add (11);
pane.add (tf1);
pane.add (12);
pane.add (tf2);
add ("North", pane);
Panel p2=new Panel();
p2.setLayout(new FlowLayout (FlowLayout. LEFT, 10,5));
p2.add(13);
p2.add (tf3);
p2.add(btn);
btn. addActionListener (this);
add ("Center", p2);
Panel p3=new Panel();
p3.setLayout(new FlowLayout (FlowLayout.LEFT,10,5));
p3.add(14);
tf4. setEditable (true);
p3.add(tf4);
add ("South", p3);
obj23_3=new ex6_3();

public void doMessure(double al,double a2,double a3,TextField tf)

double pi=Math. PI,a,b,h;
a=al*pi/180.0;
b=a2*pi/180.0;
h=a3/(1.0/Math. tan (a) -1.0/Math. tan (b));
tf.setText (Integer.toString(h));

public void actionPerformed(ActionEvent ae)

double a,b, c;
try

a=new Double(tf1.getText()) .doubleValue
b=new Double(tf2,getText ()) .doubleValue
c=new Double(tf3.getText()) .doubleValue
obj23_3.doMessure(a,b,c, tf4);
catch (NumberFormatException nfe)

tf4.setText("wrong number!");



ex6_3. html
<HTML>
<HEAD>
<TITLE>ex6_3</TITLE>
</HEAD>
<BODY>
<applet code="ex6_3.class" width=800 height=400 >
</applet>
</BODY>
</HTML>

问答题 简答题